Как купить модуль на UMI.CMS и не уронить систему

Из достоверного источника стало известно о проблемах с покупкой модулей в UMI.CMS и способах их устранения.

Дело в том, что модули в юми можно покупать и устанавливать только с версии 2.9.7. Как минимум это означает, что всем, у кого истекла лицензия, стоит её продлить (можете обратиться в А25 и мы вам с этим поможем 🙂 ).

Но, помимо явной проблемы с действующей поддержкой есть еще и неявная.

Перед покупкой модуля ОБЯЗАТЕЛЬНО нужно обновить юми. Это важное требование.

Тут нужно сказать пару слов о том как в UMI.CMS происходит установка модуля.

Собственно чтобы установить модуль нужно:

  1. Купить модуль
  2. Обновить UMI.CMS

В момент обновления ЮМИ модуль автоматически подкачивается со стороны сервера и устанавливается. НО! Только если юми умеет устанавливать тот самый подкачиваемый модуль с сервера обновлений.

А теперь представьте, что вы этого не сделаете? Обновление будет выкачивать модуль и пытаться ставить её на юми, которая не знает что делать с модулем. Из-за этого установка модуля зависнет и сайт просто не восстановится после обновления.

Если вы УЖЕ наткнулись на это, то вам сюда!

Итак, вот правильная последовательность действий при желании заполучить новый модуль в вашей чудо системе:

  1. Продлите поддержку в для UMI.CMS
  2. Обновите юми до последней версии
  3. Убедитесь, что все работает как нужно
  4. Купите модуль в ЮМИ Маркете
  5. Обновите систему еще раз

Ну и если уж совсем будет все плохо — прямая дорога вам в службу заботы ЮМИ. Слава богу, что при продленной поддержке они решают почти любые вопросы.

Простой и понятный online-курс для обучения XSLT-программиста с любого базового уровня

Ваш отзыв